Section 1. Before you start

About this tutorial

The first part of a two-part series, this tutorial explores Eclipse's Rich Client Platform (RCP). An example application shows you how to assemble an RCP to create an elegant, client-side interface for your own business applications. The application creates a front end for the Google API and gives you the ability to query and display search results. Having an application that demonstrates some of these technologies in action provides an understanding of the platform and its usefulness within some of your projects.

You should understand how to navigate Eclipse 3.0 and have a working knowledge of Java to follow this tutorial. You do not need a background in Eclipse plug-in development or an understanding of technologies such as the Standard Widget Toolkit (SWT) and JFace. You'll explore each one of these complementary technologies in detail over the course of this tutorial. After a brief introduction to these technologies, the tutorial explores the code and supporting files so you can grasp how to construct an RCP application. If you're new to Eclipse or its complementary technologies, refer to the Resources on page 30 at the end of this tutorial for more information.

Tools

Throughout the series, you'll explore various areas of the Eclipse Plug-In Development Environment in detail. While not a prerequisite, you'll find this tutorial easier to follow if you download, install, and configure Eclipse 3.0, a 1.4 Java Virtual Machine, and Apache Ant. If you don't have these tools installed, please reference, download, and install the following resources:

- Java 2 Standard Edition, Software Development Kit (SDK) is available at: http://java.sun.com/j2se/1.4.2/download.html
- Apache Ant 1.6.1 is available at: http://ant.apache.org/

About the author

Jeff Gunther, a Studio B (http://www.studiob.com/) author, is the General Manager and founder of Intalgent Technologies, an emerging provider of software products and solutions utilizing the Java 2 Enterprise Edition and Lotus Notes/Domino platforms. Jeff is an application and infrastructure architect with experience in architecting, designing, developing, deploying, and maintaining complex software systems. His diverse experience includes full lifecycle development of software running on multiple platforms, from Web servers to embedded devices. You can contact him at: jeff.gunther@intalgent.com.
Section 2. Overview of Eclipse and the RCP

The maturation of Eclipse

Over the past few years the Eclipse project has grown dramatically and matured into a powerful development environment. While you might traditionally think of Eclipse as an integrated development environment (IDE) for software development, the 3.0 release of Eclipse will broaden the scope of the platform's relevance in the marketplace. A little over a year ago members of the Eclipse community recognized that many elements of the Eclipse IDE could be utilized in non-IDE applications. When constructing business applications, developers could use the elegance of the plug-in architecture, the responsive, native-looking user interface, and the easy-to-use help system. By utilizing a common framework for developing business applications, developers can focus their energies on addressing the specific requirements of their application instead of wasting time reinventing a set of core components. Eclipse 3.0 milestone 5 introduced the development community to the RCP.

What is the RCP?

With the days of the browser wars behind us, many developers and users alike are frustrated with the lack of innovation and advancement of the desktop Web browser. While Web browsers enable organizations to deploy back-office applications to a large number of users, trying to provide a useable interface that supports multiple browsers on multiple operating systems burdens developers and managers. The RCP is an exciting concept that looks to address the need for a single cross-platform environment to create highly-interactive business applications.

Essentially, the RCP provides a generic Eclipse workbench that developers can extend to construct their own applications. An application consists of at least one custom plug-in and uses the same user-interface elements as the Eclipse 3.0 IDE. Before jumping into creating the plug-in, familiarize yourself with the basic elements of the Eclipse user interface, as Figure 1 shows.

Figure 1. The basic elements of the Eclipse user interface
The basic elements of the environment include:

1. **Workbench** -- The overarching container for all windows.
2. **Perspective** -- A visual container for all the opened views and editors.
3. **View** -- A visual container to display resources of a particular type. Typically, a view contains a data grid or tree structure. In Figure 1, the tasks view is an example of a view that is used within the Java perspective.
4. **Short Cut Bar** -- A set of icons that enables the user to quickly access different perspectives.
5. **Menu Bar** -- A set of content-sensitive actions that gives the user the ability to execute some predefined function.
6. **Tool Bar** -- A set of context-sensitive actions that enables the user to execute some predefined function. All the items found within the toolbar appear within the menu bar.
7. **Editor** -- Editors are the primary tool users employ to display and manipulate data. In the case of the Eclipse IDE, developers use an editor to edit Java source files.

### Standard Widget Toolkit and JFace
If you look at the source code that makes up the Eclipse Platform, you notice that the Java standard windowing toolkits are not used. During the development of the Eclipse Platform, the project produced two user-interface toolkits that you can use outside of the Eclipse project. These toolkits include:

- **Standard Widget Toolkit (SWT)** -- SWT provides a platform-independent API that is tightly integrated with the operating system's native windowing environment. SWT's approach provides Java developers with a cross-platform API to implement solutions that "feel" like native desktop applications. This toolkit overcomes many of the design and implementation trade-offs that developers face when using the Java Abstract Window Toolkit (AWT) or Java Foundation Classes (JFC).

- **JFace** -- The JFace toolkit is a platform-independent user interface API that extends and interoperates with the SWT. This library provides a set of components and helper utilities that simplify many of the common tasks in developing SWT user interfaces. This toolkit includes many utility classes that extend SWT to provide data viewers, wizard and dialog components, text manipulation, and image and font components.

During the development of an RCP application you extensively use the SWT and JFace classes. Refer to the Resources on page 30 for more information about these two toolkits.

---

**Eclipse plug-in architecture**

Through the influence of its predecessor, IBM Visual Age for Java, architects made the Eclipse Platform easily extensible. Figure 2 below illustrates the major components of the Eclipse architecture.

**Figure 2. The major components of the Eclipse architecture**
Outside of the base files that make up the Eclipse Platform runtime, all of Eclipse's functionality is implemented through the use of plug-ins. A plug-in is the base building block that developers use to add new capabilities and functionality to the environment. (See Resources on page 30 for an excellent developerWorks article on Developing Eclipse plug-ins.) The Eclipse runtime is responsible for managing the lifecycle of a plug-in within a workbench. All of the plug-ins for a particular environment are located in a plugin folder within the directory structure of an RCP application. Upon execution, the Eclipse runtime will discover all of the available plug-ins and use this information to create a global plug-in registry.

For a plug-in to participate within the workbench, it must define a set of extensions. An extension can add functionality directly to the base generic workbench, or extend other existing extensions. Each of these extensions is defined within a plug-in's manifest file. This XML file describes how all the extensions interoperate within the Eclipse runtime and defines the necessary dependencies. The next section covers the plug-in manifest and its tags in more detail.
Section 3. Getting started with the RCP

Steps to implement an RCP application

Before covering the specifics of developing an RCP application within Eclipse, review the general steps for implementing this type of project.

1. Identify extension points
2. Define the plug-in manifest
3. Implement extensions
4. Define the WorkbenchAdvisor class
5. Define the Application class
6. Export the application

This section shows how to access the Plug-in Development Environment and discusses the plug-in manifest.

Using the Plug-in Development Environment

One of the components of the Eclipse IDE is a specialized perspective called the Plug-in Development Environment (PDE). This perspective provides everything you need to create and package a custom Eclipse plug-in or RCP application. Access this perspective by completing the following steps:

1. Launch Eclipse 3.0 from your workstation.
2. Select Window > Open Perspective > Other from the menu bar. This action will prompt you with the Select Perspective dialog, as Figure 3 shows:

Figure 3. The Select Perspective dialog
3. Choose **Plug-in Development** from the list of perspectives and then click **OK** to display the PDE perspective Figure 4 shows:

*Figure 4. The PDE perspective*
Creating the project

With the PDE perspective opened in Eclipse, complete the following steps to create a new project:

1. Select File > New > Plug-in Project from the menu bar to display the New Plug-in Project wizard Figure 5 shows:

Figure 5. The New Plug-in Project wizard
2. Type Google into the Project name field.
3. Keep the defaulted values for this page and click Next to continue to the Plug-in Content page Figure 6 shows:
   Figure 6. The Plug-in Project Content page
4. Type `com.ibm.developerworks.google.GooglePlugin` into the Class Name field and click **Next** to continue to the Templates page.

5. Keep the defaulted values for the Templates page and click **Finish**.

---

**Understanding the plug-in manifest**

After you've completed the New Plug-in Project wizard, a project called Google will be added to the Packages Explorer and you'll be presented with a page entitled "Overview" as Figure 7 shows.

**Figure 7. Welcome to Google Plug-in**
This page is a powerful tool for editing the generated plug-in manifest. A plug-in manifest is responsible for defining the resources, dependencies, and extensions the Eclipse runtime will manage. The plug-in manifest for any project is located within the project’s root directory and is called plugin.xml. Each tab across the bottom of this editor provides you with an easy way to access and manipulate a particular section of this file.

The plugin.xml tab allows you to view the XML that each section of the editor generates. For example, below you see the content of the plug-in manifest that the New Plug-in Project wizard initially generates.

```xml
<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.0"?>
<plugin
    id="Google"
    name="Google Plug-in"
    version="1.0.0"
    provider-name=""
    class="com.ibm.developerworks.google.GooglePlugin">
```
During this discussion, you primarily use the plugin.xml view to edit the plug-in manifest. Although the editor is a helpful tool for learning the structure of a plug-in manifest, you must understand the tags it generates and how they contribute to the overall plug-in. The next two panels review each tag of a plug-in manifest and explain its purpose.

Using the plug-in manifest tags

In order to create a basic RCP application, you need to add some additional content to the plug-in manifest. Using the plugin.xml tab of the plug-in manifest editor, modify the XML within the editor to reflect the following changes:

```xml
<?xml version="1.0" encoding="UTF-8"?>
<plugin id="com.ibm.developerworks.google" name="Google Plug-in" version="1.0.0" provider-name=""
    class="com.ibm.developerworks.google.GooglePlugin">
    <runtime>
        <library name="Google.jar">
            <export name="*"/>
        </library>
    </runtime>
    <requires>
        <import plugin="org.eclipse.ui"/>
        <import plugin="org.eclipse.core.runtime.compatibility"/>
    </requires>
</plugin>

<extension id="googleApplication" point="org.eclipse.core.runtime.applications">
    <application>
        <run class="com.ibm.developerworks.google.GoogleApplication"/>
    </application>
</extension>

<extension point="org.eclipse.ui.perspectives">
    <perspective
        name="Google"
        class="com.ibm.developerworks.google.GooglePerspective"/>
</extension>
```
Next, you'll explore this plug-in manifest in detail.

Stepping through the plug-in manifest

Beginning with the <plugin> element, lines 3 through 8 start defining the body of the plug-in manifest. This base tag contains all the extensions, extension points, dependencies, and runtime constraints of the plug-in. In addition, the <plugin> tag has the following five attributes:

1. name -- This attribute defines the general name of the plug-in.
2. id -- This attribute defines a unique identifier for the plug-in. To reduce any naming collisions, you should derive this attribute from the Internet domain of the plug-in's author. In this example, the id for this plug-in has been changed to com.ibm.developerworks.google. This practice is consistent with other Java naming conventions like class packaging.
3. version -- This attribute defines the plug-in version in a major.minor.service format.
4. provider-name -- This attribute defines the author of this plug-in.
5. class -- This attribute defines the name of the plug-in class. Although a plug-in class is defined, an RCP application does not use this class during execution.

Lines 10 through 14 define the runtime section of the plug-in manifest. Similar to the concept of a classpath within a Java application, this section defines any local Java libraries that are necessary during execution. Each Java library is listed within the <runtime> element by using a <library> element. The library element can contain a series of nested <export> elements. Each export element defines the export mask for that particular library.

Lines 16 through 19 contain a <requires> element that defines any dependencies on other plug-ins. Each plug-in is itemized through the use of a single <import> element.

Lines 21 through 37 define two <extension> elements that the RCP application will use. The next panel reviews the basic concepts of extensions and extension points. The <extension> element has the following three attributes:

1. point -- This attribute defines a reference to an extension point being configured.
2. id - This optional attribute defines an identifier for this extension point configuration instance.
3. name - This optional attribute defines a general name for this extension.

Understanding extensions

As previously mentioned in the Eclipse plug-in architecture on page 5 panel, the Eclipse Platform is extremely extensible through the use of a relatively small runtime
kernel and its elegant plug-in architecture. The use of plug-ins adds new functionality to the runtime kernel. Each plug-in can contain any number of extensions that are integrated through the use of extension points. Similarly, a plug-in can define its own set of extension points that other developers can utilize within their own plug-ins or RCP applications.

Examine the two <extension> elements of the previously presented plug-in manifest.

```xml
1 ... 
2 <extension id="googleApplication"
3 point="org.eclipse.core.runtime.applications">
4 <application>
5 <run class="com.ibm.developerworks.google.GoogleApplication"/>
6 </application>
7 </extension>
8
9 <extension point="org.eclipse.ui.perspectives">
10 <perspective
11 id="com.ibm.developerworks.google.GooglePerspective"
12 name="Google"
13 class="com.ibm.developerworks.google.GooglePerspective"/>
14 </extension>
15 ...
```

Lines 2 through 7 define the first extension through the org.eclipse.core.runtime.applications extension point. This extension declares the entry point for an RCP application. Within this extension element, an <application> element is defined. A <run> element is within this tag. This <run> element contains the class name that will be executed when the RCP application is started. The second extension is between lines 10 through 17. This extension defines a perspective through an extension point entitled org.eclipse.ui.perspectives. This extension point adds perspectives to the generic workbench. The next section explores the use of perspectives in more detail.

For more information about the various types of extension points that come with Eclipse 3.0, refer to the Resources on page 30.
Section 4. Defining a perspective

Overview of perspectives

Perspectives within the Eclipse workbench are a visual container for all opened views and editors. In the previous panel, Using the Plug-in Development Environment on page 7, you opened a specialized perspective called the PDE to start the Google plug-in project. This perspective is specifically designed to provide developers with a set of tools to develop custom plug-ins. End users of the perspective can see that the creators of the PDE paid a lot of attention to the location and placement of the tools within the workbench. As you begin the process of creating perspectives within your own RCP applications, take into account the following considerations:

1. Define the perspective's purpose -- Since the Eclipse workbench only displays a single perspective at a time, you want to group logical and functional areas of your application into a unified perspective. This approach minimizes the need for the user to toggle between different perspectives to accomplish a particular task. As you work through and define each perspective's purpose, also keep in mind that a view or editor cannot be shared between different perspectives. The number of perspectives that any application will have is largely dependent on the application's size and complexity. For our example Google application, only one perspective is initially defined.

2. Define the perspective's behavior -- Depending on your application, a perspective with its collective views, editors, and actions can be designed to perform distinct functions. For example, the Java Browsing perspective within Eclipse 3.0 is designed to provide you various types of information that are filtered based on a set of selection criteria. This perspective's behavior filters information for you using a series of consecutive views. In contrast, the Java perspective is a collection of views, editors, and actions that give you the ability to edit and compile Java code. This perspective's behavior is task-oriented and gives the end user a set of tools to accomplish a particular goal.

Creating a basic perspective

After creating your plug-in project, creating a perspective is a two-step process. First, modify the plug-in manifest to include a new extension that uses the org.eclipse.ui.perspectives extension point. Second, using the attributes from the new extension point, create a perspective class. Based on the earlier discussion of extensions and extension points, the plug-in manifest for the Google application already includes the following extension:

```xml
...<extension point="org.eclipse.ui.perspectives">
  <perspective
    id="com.ibm.developerworks.google.GooglePerspective"
    name="Google"
    class="com.ibm.developerworks.google.GooglePerspective"/>
</extension>
...```

The `<perspective>` element has the following attributes:
° id -- This attribute defines a unique identifier for the perspective.
° name -- This attribute defines a name for this perspective, and the workbench window menu bar uses it to represent this perspective.
° class -- This attribute contains the fully qualified name of the class that implements the org.eclipse.ui.IPerspectiveFactory interface.

Creating a basic perspective, continued

To create the perspective class within the Google project, complete the following steps:

1. Select **File > New > Class** from the menu bar to display the New Java Class wizard.

   **Figure 8. New Java Class wizard**
2. Type **GooglePerspective** into the Name field.
3. Click on the **Add** button to display the Implemented Interfaces Selection dialog box.
4. Type **org.eclipse.ui.IPerspectiveFactory** into the Choose Interfaces field and click **OK**.
5. Click the **Finish** button to create the new class.

The wizard generates the following source code:

```java
1 package com.ibm.developerworks.google;
2 import org.eclipse.ui.IPageLayout;
3 import org.eclipse.ui.IPerspectiveFactory;
```
The `createInitialLayout` method found on lines 8 through 10 defines the initial layout of all the views and editors within the perspective. For the time being, you don’t need to modify this method. You’ll modify it in Part two of this series once you define a view.
Section 5. Defining the WorkbenchAdvisor and Application classes

Introducing the WorkbenchAdvisor

The previous panels have focused on the various components that contribute to an RCP application. The next series of panels focus on pulling everything together. One of the core tasks in constructing an RCP application is to create a class that implements the abstract class org.eclipse.ui.application.WorkbenchAdvisor. The WorkbenchAdvisor class is responsible for configuring the workbench that displays when an RCP application executes.

The WorkbenchAdvisor class contains the following methods that provide developers access to the lifecycle of the generic workbench:

- **initialize** -- This method is called first before any windows are displayed.
- **preStartup** -- This method is executed second, but is called before the first window is opened. This method is useful to temporarily disable items during startup or restore.
- **postStartup** -- This method is called third after the first window is opened and is used to re-enable items temporarily disabled in the preStartup method.
- **postRestore** -- This method is called after the workbench and its windows have been recreated from a previously-saved state.
- **preShutdown** -- This method is called just after the event loop has terminated, but before any windows have been closed.
- **postShutdown** -- This is the final method that is called after the event loop has terminated.

The WorkbenchAdvisor class contains the following methods that provide developers access to the lifecycle of the workbench window:

- **preWindowOpen** -- This method is called as each window is opened.
- **fillActionBars** -- This method is called after the preWindowOpen method, and it configures a window's action bars.
- **postWindowRestore** -- This method is called after a window has been recreated from a previously-saved state.
- **postWindowOpen** -- This method is called after a window has been opened. This method is useful to register any window listeners.
- **preWindowShellClose** -- This method is called when the user closes the window's shell.

The WorkbenchAdvisor class contains the following methods that provide developers access to the event loop of the workbench:

- **eventLoopException** -- This method is called to handle the exception of the event loop crashing.
- **eventLoopIdle** -- This method is called when no more events need to be processed.
Creating the WorkbenchAdvisor class

To create a WorkbenchAdvisor class, complete the following steps from within the PDE:

1. Select **File > New > Class** from the menu bar to display the New Java Class wizard.
2. Type **GoogleWorkbenchAdvisor** into the Name field.
3. Click on the **Browse** button to display the Superclass Selection dialog box.
4. Type **org.eclipse.ui.application.WorkbenchAdvisor** into the Choose a type field and click **OK**.
5. Click the **Finish** button to create the new class.

The wizard generates the following source code:

```java
package com.ibm.developerworks.google;
import org.eclipse.ui.application.WorkbenchAdvisor;

public class GoogleWorkbenchAdvisor extends WorkbenchAdvisor {
    public String getInitialWindowPerspectiveId() {
        return null;
    }
}
```

You need to make a few minor modifications to this class before you try to execute the RCP application within the PDE. First, you need to modify the `getInitialWindowPerspectiveId` method on lines 7 through 9. This method should return the identifier of the initial perspective for the new workbench window. Since you defined the Google perspective in the previous section as `com.ibm.developerworks.google.GooglePerspective`, this string will be returned to the calling function. Second, you need to add a method called `preWindowOpen`. This method allows you to set the workbench's window title and size. See the modified class below:

```java
package com.ibm.developerworks.google;
import org.eclipse.swt.graphics.Point;
import org.eclipse.ui.application.IWorkbenchWindowConfigurer;
import org.eclipse.ui.application.WorkbenchAdvisor;

public class GoogleWorkbenchAdvisor extends WorkbenchAdvisor {
    public String getInitialWindowPerspectiveId() {
        return "com.ibm.developerworks.google.GooglePerspective";
    }

    public void preWindowOpen(IWorkbenchWindowConfigurer configurer) {
        super.preWindowOpen(configurer);
        configurer.setTitle("Google");
        configurer.setInitialSize(new Point(300, 300));
    }
}
```
Creating the Application class

Before executing the application, you need to create an Application class. Similar to the main method within a Java class, this class is the main entry point for the RCP application. This class implements the org.eclipse.core.runtime.IPlatformRunnable interface as defined within the plug-in manifest under the org.eclipse.core.runtime.applications extension point.

To create an Application class, complete the following steps from within the PDE:

1. Select File > New > Class from the menu bar to display the New Java Class wizard.
2. Type GoogleApplication into the Name field.
3. Click on the Add button to display the Implemented Interfaces Selection dialog box.
4. Type org.eclipse.core.runtime.IPlatformRunnable into the Choose Interfaces field and click OK.
5. Click the Finish button to create the new class.
6. Add the following run method to the generated class. For most RCP applications, this run method will not need to be customized and can be re-used.

```java
public Object run(Object args) throws Exception {
    WorkbenchAdvisor workbenchAdvisor = new GoogleWorkbenchAdvisor();
    Display display = PlatformUI.createDisplay();
    int returnCode = PlatformUI.createAndRunWorkbench(display,
            workbenchAdvisor);
    if (returnCode == PlatformUI.RETURN_RESTART)
        return IPlatformRunnable.EXIT_RESTART;
    else
        return IPlatformRunnable.EXIT_OK;
}
```

Launching the application with the PDE

To launch the application within the PDE, complete the following steps:

1. Select Run > Run... from the menu bar to display the Run dialog as Figure 9 shows.

   Figure 9. The Run dialog
2. Highlight **Run-time Workbench** within the Configurations field and click the **New** button to display a new run-time workbench configuration as Figure 10 shows: **Figure 10. A new Run-time Workbench configuration**
3. Type **Google** into the Name field.
4. Select **Google.googleApplication** from the Application Name field.
5. Click on the Plug-ins tab as Figure 11 shows:
   *Figure 11. The Plug-ins tab of the Run dialog*
6. Select the radio button **Choose plug-ins and fragments to launch from the list**.
7. Click the **Deselect All** button.
8. Check the **Workspace Plug-ins** option. This also selects the Google project.
9. Click the **Add Required Plug-ins** button. This action determines which plug-ins are necessary to execute the application. You will use this list when you assemble the stand-alone application.
10. Click the **Apply** button.
11. Click the **Run** button to execute the application. If everything is configured properly, a window entitled "Google" should display as Figure 12 shows. Although this window doesn't perform any function, it does demonstrate how you can use the PDE to create a generic workbench.

**Figure 12. The new Google window**
Section 6. Creating a stand-alone application

Exporting the application

So far you have focused on how to run an RCP application within the Eclipse IDE. In this section, you’ll focus on how to create a stand-alone application by completing the following steps within the PDE:

1. Select **File > Export...** from the menu bar to display the Export dialog as Figure 13 shows:
   **Figure 13. The Export dialog**

   ![Export dialog](image)

2. Select **Deployable plug-ins and fragments** from the list of export options.
3. Click **Next** to display the Export Plug-ins and Fragments page of the Export wizard as Figure 14 shows:
   **Figure 14. Export Plug-ins and Fragments page of the Export wizard**

![Export Plug-ins and Fragments page](image)
4. Check the Google plug-in.
5. Select a directory structure under the Deploy as field.
6. Click the Browse button and choose an export location.
7. Click Finish to build the project.

Preparing the directory structure

To complete the stand-alone application, you need to copy some files from the Eclipse IDE directory into Google's export directory. Unfortunately, Eclipse 3.0 doesn't provide a tool to copy all the necessary dependent plug-ins and JAR files into the export directory, so you need to complete the following steps:
1. Copy startup.jar from the root directory of the Eclipse 3.0 IDE to the root of the Google application's export directory.

2. Copy the following directories from the Eclipse 3.0 IDE plug-in directory to the plugin directory of the Google application's export directory:
   - org.eclipse.core.expressions_3.0.0
   - org.eclipse.core.runtime_3.0.0
   - org.eclipse.help_3.0.0
   - org.eclipse.jface_3.0.0
   - org.eclipse.osgi_3.0.0
   - org.eclipse.swt.win32_3.0.0 (Windows only)
   - org.eclipse.swt.gtk_3.0.0 (Linux only)
   - org.eclipse.swt_3.0.0
   - org.eclipse.ui.workbench_3.0.0
   - org.eclipse.ui_3.0.0
   - org.eclipse.update.configurator_3.0.0

Testing the application

To test the application, you need to create a launch script. Using your favorite text editor, create a file entitled google.bat (Windows) or google.sh (Linux) with the following content:

```bash
java -cp startup.jar org.eclipse.core.launcher.Main -application com.ibm.developerworks.google.googleApplication
```

After you've completed this task, your export directory should have the following structure:

- google.bat (Windows only)
- google.sh (Linux only)
- startup.jar
  + ----- plugins
    + ----- org.eclipse.core.expressions_3.0.0
    + ----- org.eclipse.core.runtime_3.0.0
    + ----- org.eclipse.help_3.0.0
    + ----- org.eclipse.jface_3.0.0
    + ----- org.eclipse.osgi.services_3.0.0
    + ----- org.eclipse.osgi.util_3.0.0
    + ----- org.eclipse.osgi_3.0.0
    + ----- org.eclipse.swt.win32_3.0.0 (Windows only)
    + ----- org.eclipse.swt.gtk_3.0.0 (Linux only)
    + ----- org.eclipse.swt_3.0.0
    + ----- org.eclipse.ui.workbench_3.0.0
    + ----- org.eclipse.ui_3.0.0
    + ----- org.eclipse.update.configurator_3.0.0
Section 7. Summary and resources

Summary

The RCP will extend and evolve as developers begin to understand and utilize it within their applications. Although we have only barely developed the example application, the companion source code and plug-in manifest demonstrate how to construct a basic RCP application. While this first tutorial provided an overview of the RCP, the next part of this series explores the inner-workings of the generic workbench and the development of the Google RCP application.

Resources

- Download (part1-src.zip) the companion source code package for the sample RCP application demonstrated in this tutorial.
- Download Java 2 SDK, Standard Edition 1.4.2 (http://java.sun.com/j2se/1.4.2/download.html) from Sun Microsystems.
- Download Ant 1.6.1 (http://ant.apache.org/) or higher from the Apache Software Foundation.
- Get an introduction to the core components of the Eclipse Platform from the whitepaper, "Eclipse Technical Overview" (Eclipse Web site).
- Find more resources for developing plug-ins on the Eclipse Web site, including, Platform Extension Points (Eclipse Web site).
- Find more resources for how to use the Standard Widget Toolkit and JFace on developerWorks, including:
  - Integrate ActiveX controls into SWT applications (developerWorks, June 2003)
  - Developing JFace wizards (developerWorks, May 2003)
  - Integrate ActiveX controls into SWT applications (developerWorks, June 2003)
- Find more resources for how to use Eclipse on developerWorks, including:
  - Developing Eclipse plug-ins (developerWorks, December 2002)
  - XML development with the Eclipse Platform (developerWorks, April 2003)

Colophon

This tutorial was written entirely in XML, using the developerWorks Toot-O-Matic tutorial generator. The open source Toot-O-Matic tool is an XSLT stylesheet and several XSLT extension functions that convert an XML file into a number of HTML pages, a zip file, JPEG heading graphics, and two PDF files. Our ability to generate multiple text and binary formats from a single source file illustrates the power and flexibility of XML. (It also saves our production team a great deal of time and effort.)

For more information about the Toot-O-Matic, visit www-106.ibm.com/developerworks/xml/library/x-toot/.